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SuperLab 4
Basic Procedures for OSU Students and Faculty
Featuring Two Sociolinguistic Experiments
and a Short Overview
This procedures guide is intended to supplement the SuperLab 4 user’s manual and to
provide information of specific use to OSU English Dept. students and faculty. Prior
familiarity with the manual will help you understand this document, but it is not required.
1. Experiment #1: Rhoticity and hearer expectations.
The following is a step‐by‐step example of a sociolinguistics experiment that happens to
demonstrate some of the most common operations in SuperLab 4. The example presents
only the most basic steps for setting the experiment, giving you a good feel for how the
process works in the hope that you could modify it for your own purposes later.
1.1. Background.
Say that you want to test hearer expectations of certain sociolinguistic factors relating to a
speaker when the hearer is presented only with auditory stimuli, as in the case of talking to
a stranger on the telephone. More specifically, you want to know if, when a person simply
hears non‐rhotic (r‐less, e.g., in certain British dialects) versus rhotic (with r, e.g., in certain
American dialects) speech, they automatically conjure a mental image of the speaker with a
specific age, ethnicity, social status, physical attractiveness level, or emotional state despite
the fact that they have no visual reinforcement for such an assumption.
1.2. Experimental design.
This experiment will require the participant to be first presented with auditory stimuli, of
either non‐rhotic or rhotic speech, followed then by a choice of two photographs. The
participant will then have to choose which of the people in the two photographs is more
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likely to have recorded the speech sample. Because you want to test how strong the
expectations are, you will want to measure the participant’s response times; assume that
the stronger the expectation is, the faster the reaction times are. Note: There are already
audio samples and photographs for use in this experiment, but they are less than ideal.
1.3. Setting up the experiment.
Follow the steps below to create this experiment:
1.

Either open SuperLab 4 anew or click File > New in the SuperLab menu to start a
new experiment.

2.

Click in the white area under Blocks to select this unit. In the toolbar above, click on
the green plus sign to create a new block (think of a block as a generic container for
certain experimental structures). Type Introduction in the Block Name: field. Hit
the OK button. Click on the green floppy disk icon in the toolbar to save your
experiment. You will be prompted to name your experiment. Call it
RhoticExpectations.

3.

Do the same thing again but in the Trials area instead. It, too, should be named
Introduction. Note that unique names are required in each area, but items from
different areas can have the same name. Save the experiment.

4.

Repeat again for the Events area. Here, though, click on the Stimulus tab if it is not
already selected. Use the pull‐down menu for Event Type to specify a Text event. In
the Use Text menu, select Text That I Enter Below.
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In the large text box under the Use Text menu, enter the following text to be used as
a visual stimulus:
In the following experiment, you will first hear an audio
sample of some recorded speech. You will then see
photographs of two people. It will then be your job to
determine which of the two people is more likely to
have recorded the speech sample.
Press the lowercase g if you think the person on the
left is more likely to have recorded the sample. Press
the lowercase h if you think the person on the right
is more likely to have recorded the sample. Press the
space bar if you can’t decide or if you feel both people
are equally likely to have recorded the sample.
Press any key to continue.
Click on Settings… to the right of the text. Under the Presentation Options tab,
make sure the Erase Screen option is checked in the At Event End: menu. Click OK.
Back at the Event Editor, go to the Input tab. Look under the End This Event and
Move to the Next One options. Make sure the After any response from the
participant option is the only one checked. At the bottom of the screen, make sure
that neither the Record and save response option nor the Reset RT timer option
is checked. Click OK. Save the experiment.
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Set up an input device by going to the Experiment > Participant Input… menu.
Click on the KeyboardSingle Keys option. Click Done. Save the experiment.

6.

Go to the Experiment > Participant Input… menu. Click New…. Name this
keyboard response Left option (g). In the field for The following key:, type g. Click
OK. Click New…. Name this keyboard response Right option (h). In the field for The
following key:, type h. Click OK. Click New…. Name this keyboard response Either
option (space). In the field for The following key:, just hit the space bar once. Click
OK. Click Done in the Participant Input editor. Save the experiment.

7.

If there is grey highlighting on any item name, clear it by clicking in the white “field”
of the area that the item is in. When all grey highlighting is gone, click on the
Introduction trial. Associate the Introduction event to the Introduction trial by
clicking in the blue box next to the event name. A small check mark will appear
when successful. Save the experiment.

8.

Associate the Introduction trial to the Introduction block following the same
procedure. Save the experiment.

9.

Although the experiment doesn’t do much this point, you can now run it. Click the
green arrow icon in the toolbar above the Events area. Deselect both the Save
collected data and the Run selected blocks only options. Since you’re not saving
data, you don’t need to enter a participant name. Just click Run. You’ll notice that
the experiment doesn’t do much, yet, but that it does run as expected.

10.

Create a new block named Block1. Save the experiment.
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Create two new trials, one named MaleStimuli and one named FemaleStimuli. Save
the experiment.

12.

Create a new event named MaleAudio. Set it up as an audio file. For the Use field,
select the A File Chosen From the List: option and click Create List…. Title the list
MaleList and click Add Files…. Navigate to Applications > SuperLab > Basic
Procedures Experimental Files and select first nonrhoticmale.wav and then
rhoticmale.wav.* Click OK. While still in the Stimulus tab, deselect the Wait for
audio to finish playing option if it is already selected. Then, under the How to end
audio: menu, select Allow audio to continue playing until it ends on its own.
Wait for audio to end before ending. Once it is selected, select the Wait for audio
to finish playing option. Under the Input tab, select the Immediately after the
event is presented option. Also, deselect the Record and save response and
Reset RT timer options. Hit OK. Save the experiment.

*Note that the audio files used in this example are actually computergenerated, and
are not at all ideal in such an experiment. Still, once you understand how to set up the
experiment, you can easily go back and replace the audio and even the visual cues to
whatever is most appropriate for the experiment you would like to design.

13.

Use a slightly different method to create a parallel stimulus list for the female audio
files. Go to Experiment > Stimulus Lists… and click the green plus sign to create a
new list. Call it FemaleList and add the files nonrhoticfemale.wav and then
rhoticfemale.wav. Click OK. Click Done on the Stimulus Lists editor. Save the
experiment.

14.

Create an event named FemaleAudio with all the properties of MaleAudio but using
audio files from the list FemaleList. Save the experiment.
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Use the Stimulus Lists editor to create a new list called MalePhotoLeft. Add the
following picture files from the Basic Procedures Experimental Files folder in this
order:
morwah.jpeg (stands for Male Older euRopean Wealthy Attractive Happy; a similar
format is used for all files used in this document; this file will be used to test age
expectations)
morwnu.jpeg (will be used to test ethnicity expectations)
morpnu.jpeg (will be used to test social class expectations)
morwnh.jpeg (will be used to test physical attractiveness expectations)
morwnu.jpeg (will be used to test emotional state expectations)
When adding the last file, SuperLab will warn you that you are using a file that
already exists on the list. Click Yes on the warning screen.
Create a new list called MalePhotoRight. Add the following picture files:
myrwah.jpeg (will be used to test age expectations)
moswnu.jpeg (will be used to test ethnicity expectations)
morwnu.jpeg (will be used to test social class expectations)
morwah.jpeg (will be used to test physical attractiveness expectations)
morwnh.jpeg (will be used to test emotional state expectations)
Click Done on the Stimulus Lists editor. Save the experiment.

16.

Using the same technique, create a new list called FemalePhotoLeft. Add the
following picture files:
forwah.jpeg (will be used to test age expectations)
fyrwau.jpeg (will be used to test ethnicity expectations)

SuperLab 4 Basic Procedures

7

OSU English Dept.

forpnu.jpeg (will be used to test social class expectations)
forwah.jpeg (will be used to test physical attractiveness expectations)
fyrwau.jpeg (will be used to test emotional state expectations)
Create a new list called FemalePhotoRight with the following picture files:
fyrwah.jpeg (will be used to test age expectations)
fyswau.jpeg (will be used to test ethnicity expectations)
forwnu.jpeg (will be used to test social class expectations)
forwnh.jpeg (will be used to test physical attractiveness expectations)
fyrwah.jpeg (will be used to test emotional state expectations)
Save the experiment.

17.

Create a new photo event called MaleLeft. Have SuperLab choose picture files from
the stimulus list MalePhotoLeft. Click on Settings… to the right of the large blue
panel. Under the Position tab, change the Horizontally (X) value to ‐288 pixels (this
is supposed to be a negative number, so be sure to include the negative sign). Under
the Size tab, select I want to specify a frame size. Then, set the Width (X) value to
108 and the Height (Y) value to 144. Under the Presentation Options tab, select
both the Erase screen before presenting stimulus and Keep stimulus invisible
options. Make sure the Do Nothing option is checked in the At Event End: menu.
Click OK on the Picture Settings editor. In the Event Editor, move to the Input tab.
Click OK. Select the Immediately after the event is presented and the Reset RT
Timer options. Click OK. Use the up and down arrows on the toolbar to move the
event just below the MaleAudio event. Save the experiment.

18.

Create a new photo event called MaleRight that chooses picture files from the
stimulus list MalePhotoRight. In the Picture Settings editor, change the horizontal
position value to 288 pixels and the frame size 108 width and 144 height. Under the
Presentation Options tab, select ONLY the Erase Screen option (under At Event
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End:) is selected. Click OK. Back at the Event Editor, go to the Input tab. Select After
a correct response from the participant and Record and save responses. Click
on the Correct Response tab. Select all the picture files using the shift button while
clicking. Under …the correct response is:, select One or more of the following:.
Check each of the three responses. Click OK. Move the event just below MaleLeft.
Save the experiment.

19.

Associate the MaleAudio, MaleLeft, and MaleRight events with the MaleStimuli
trial. Then associate the MaleStimuli trial to Block1. Save the experiment.

20.

Create an event called FemaleLeft identical in every way to MaleLeft with the
exception that it should choose images from the FemalePhotoLeft list. Arrange it
under FemaleAudio. Save the experiment.

21.

Create an event called FemaleRight identical in every way to MaleRight with the
exception that it should choose images from the FemalePhotoRight list. Arrange it
under FemaleLeft. Save the experiment.

22.

Associate the FemaleAudio, FemaleLeft, and FemaleRight events with the
FemaleStimuli trial. Then associate the FemaleStimuli trial to Block1. Save the
experiment.

23.

Run the experiment to see if it works to your satisfaction. This time, though, give the
participant a name and make sure that the Save collected data option is checked.
When you click Run, you will be prompted to specify a filename and location for the
data file. After running it, locate your data and view it to get a feel for how SuperLab
records data.
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1.4. Extending the experiment.
In its present state, the experiment does the bare minimum of what it is intended to do. But
will the experiment generate reliable data from beginning to end? Probably not. Right now,
the participants have no chance to learn the basic mechanics of how to perform their role in
the trial except by participating in the trial. This means that they are likely to show slower
reaction times for items appearing at the beginning of the trial, when the whole process is
new, than they show for items appearing at the end of the trial, when they are more
familiar with what to look and listen for and where to place their hands to maximize their
speed. It would, therefore, be beneficial not only for participants’ confidence but to the
overall integrity of the data to provide a mechanism by which they can practice running the
trial before data is collected.

One way to do this is to incorporate a brief practice block called, say, Practice, making use of
“dummy” cues and collecting no data. Practice will be run between Introduction and
Block1. It should have the exact same format as Block1, with the exception that it will
have only one trial called, say, Practice. Practice will be exactly the same as either
MaleStimuli or FemaleStimuli, except that it can use any two photos and any audio cue of
your choice for an event since no data will be collected. A series of perhaps three or four
such matching exercises will then be followed with a simple text event prompting the
participant to hit any key to continue. In essence, this block is will give participants a
moment or two to practice the procedures before data will be collected—and this is always
a good idea. Be sure when using such a practice block to revise the text of the Introduction
event to explain the practice procedure.

At this point in your experience with SuperLab, you should be able to generate this
Practice block and all its necessary components. Try and see what you can do following the
procedures and purposes described above.
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2. Experiment #2: Pin/pen merger.
The following is a step‐by‐step example of a sociolinguistics experiment of special interest
to researchers of Oklahoma dialects. The experiment builds on some of the techniques
demonstrated in Experiment #1; if you have not already covered that one, please do so
before moving on to this one.
2.1. Background.
Say that you want to test the salience of the contrast between [ɪ] and [ɛ] before nasals for a
given set of participants. If a participant has the contrast, then she will presumably produce
and detect a difference in pronunciation between English pin [phɪn] and pen [phɛn]. On the
other hand, if [ɪ] and [ɛ] have merged before nasals, a participant may produce both words
as [phɪn]. Such a merger is generally believed to be common in Oklahoma, particularly
among older and more rural English speakers. However, recent dialectological work in the
state suggests that younger, more urban speakers may have acquired the contrast. If so,
then these speakers may have come to associate the merger with older individuals or more
rural individuals. Additionally, young speakers may expect a greater degree of contrast
among female speakers versus male speakers.
Note that a similar merger and contrast pattern exists in Oklahoma between [ɑ] and [ɔ] as
in cot and caught, respectively. One would, therefore, assume that an experiment designed
to test the expected merger or contrast of [ɪ] and [ɛ] may be used to detect merger or
contrast of [ɑ] and [ɔ] with relatively minor modifications.
2.2. Experimental design.
For this experiment, the participant will be exposed to several stimuli all at once. On the
left edge of the screen there will be a text cue, such as the word ‘PIN,’ and on the right,
‘PEN.’ In the center of the screen, there will be a photograph of an individual—male or
female, old or young, rural or urban. The participant will then hear an audio recording of,
say, ‘pin.’ The participant, drawing on cues from the photograph, will probably assume that
the voice on the recording belongs to the person in the photograph. Acting on this
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information, the participant must decide which of the two words matches the recording.
The idea is that younger participants, for example, may assume that [phɪn] represents pin
when it accompanies a younger, more urban, or female face, but may have a harder time
(and exhibit longer response times) when [phɪn] accompanies an older, more rural, or male
face. Note: There are already audio samples and photographs for use in this experiment,
but they are less than ideal; feel free to use your own or modify the existing ones.
2.3. Setting up the experiment.
Follow the steps below to create this experiment:
1.

Create a new experiment.

2.

Create a new block, a new trial, and a new event all called Introduction. Click on the
green floppy disk icon in the toolbar to save your experiment. You will be prompted
to name your experiment. Call it PinPenPhoto.

3.

In the SuperLab menu, go to Experiment > Participant Input…. Select Keyboard
Single Keys. Click New… and make response called Left word correct (1). Set the field
value of The following key: to 1. Click OK. Make a new list called Right word correct
(3) and set the value to 3. Make a third list called Continue (space) and hit the space
bar in the field for The following key:. Back in the main Participant Input editor
window, go to the Options tab. Under the Look for Single Key Responses From
Participants: menu, select Only if an event designates a single key response as
correct. Click Done. Save the experiment.

4.

For the Introduction event, specify it as a text event, and provide the following text
for it:
In the following experiment, you will see a picture
and hear an audio sample of recorded speech. You
will also see two printed words. Your job is to pick
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which of the two printed words best matches the
the word in the recording.
Press the number 1 on the 10‐key number pad if you
think the word on the left is the best match. Press
the number 3 on the 10‐key number pad if you think
the word on the right is the best match.
Press the space bar to continue.
Click Settings… to the right of the text panel. Under the Presentation Options tab
of the Text Settings editor, select only Erase screen before presenting stimulus
and, in the At Event End: menu, Erase Screen. Click OK. Under the Input tab of the
Event Editor, select After a correct response from the participant and deselect
both Record and save response and Reset RT timer. Under the Correct Response
tab, set the …the correct response is: menu to One or more of the following: and
choose Continue (space). Click OK. Save the experiment.
5.

Associate the event Introduction to the trial Introduction and the trial to the block
Introduction. Save the experiment.

6.

Create a new block called Block1 and a new trial called Stimuli. Save the experiment.

7.

Create new text events called LeftWords and RightWords. Save the experiment.

8.

For LeftWords, under the Stimulus tab, choose Use Text: Text Chosen from the
List: and create a new list called LeftWordList. Add the words in the following list
below, one word per line (do not include commas):
DIM, SET, PEN, FIN, CHEM, FIT, SITE, DIN, HEM, BED, GEM, BIN, PIN, PEN, JIM, GEM, HIM,
HID, DEM, KIN, BEN, TIN, BIN, TEN, DIM, BIG, PIG, CHEM, FIT, HIM, BEN, DRIP, BED, HEM,
SIT, KEN, KIM, BIT, KEN, JIM, DEM, TIN, KIM, PIN, TEN, BEG, BID, and SIGHED.
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Note that about one third of these words are filler words designed NOT to test the
pin/pen merger. Click on Settings…. Under the Position tab, set the Horizontally
(X) value to ‐360. Under the Presentation Options tab, select only Keep stimulus
invisible and, under the At Event End: menu, Do Nothing. Click OK. Go to the
Input tab. Select Immediately after the event is presented and deselect Record
and save response and Reset RT timer. Click OK. Save the experiment.
9.

Go to Experiment > Stimulus Lists… and create a new stimulus list of List Type:
Text called RightWordList. Add the words in the following list, one word per line (do
not include commas):
DEM, SIT, PIN, THIN, KIM, HIT, SIGHED, DEN, HIM, BET, JIM, BEN, PEN, PIN, GEM, JIM,
HEM, HIT, DIM, KEN, BIN, TEN, BEN, TIN, DEM, BEG, PEG, KIM, FIN, HEM, BIN, GRIP, BID,
HIM, FIT, KIN, CHEM, BIG, KIN, GEM, DIM, TEN, CHEM, PEN, TIN, PEG, BED, and SIGN.
Click Done. Save the experiment.

10.

For RightWords, under the Stimulus tab, choose Use Text: Text Chosen from the
List: and select RightWordList. Click on Settings…. Under the Position tab, set the
Horizontally (X) value to 360. Under the Presentation Options tab, select only
Keep Invisible and also Do Nothing the At Event End: menu. Click OK. Under the
Input tab, Select only Immediately after the event is presented. Click OK. Save
the experiment.

11.

Go to Experiment > Stimulus Lists… and create a new stimulus list of List Type:
Text called ComboList. Copy the following text and past it into the field (be aware of
the highlighted entries—this will be important in the next step):
MYU:DIM~DEM=DIM
FOU:SET~SIT=SET
FOR:PEN~PIN=PIN
FYU:FIN~THIN=FIN
MOR:CHEM~KIM=KIM
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FYR:FIT~HIT=FIT
MYU:SITE~SIGHED=SIGHED
FOR:DIN~DEN=DIN
MYU:HEM~HIM=HEM
MOU:BED~BET=BET
FOU:GEM~JIM=GEM
MOR:BIN~BEN=BIN
MYU:PIN~PEN=PEN
FOU:PEN~PIN=PEN
MOU:JIM~GEM=GEM
FYU:GEM~JIM=JIM
FYU:HIM~HEM=HEM
MYU:HID~HIT=HIT
FYR:DEM~DIM=DEM
FYR:KIN~KEN=KEN
FOR:BEN~BIN=BEN
FOU:TIN~TEN=TIN
MOR:BIN~BEN=BEN
MOR:TEN~TIN=TEN
MYR:DIM~DEM=DEM
MYR:BIG~BEG=BIG
FOU:PIG~PEG=PEG
MYR:CHEM~KIM=CHEM
FOR:FIT~FIN=FIN
FYR:HIM~HEM=HIM
FYR:BEN~BIN=BIN
MOR:DRIP~GRIP=DRIP
FYU:BED~BID=BID
MYU:HEM~HIM=HIM
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MOU:SIT~FIT=SIT
MOU:KEN~KIN=KEN
FYU:KIM~CHEM=KIM
MYR:BIT~BIG=BIT
MOU:KEN~KIN=KIN
MYR:JIM~GEM=JIM
FOU:DEM~DIM=DIM
FOR:TIN~TEN=TEN
FYU:KIM~CHEM=CHEM
MYR:PIN~PEN=PIN
MOU:TEN~TIN=TIN
FOR:BEG~PEG=BEG
FYR:BID~BED=BED
MOR:SIGHED~SIGN=SIGHED
Click Done. Save the experiment.
12.

Create a new text event called ComboStimuli. Set the program so that it chooses from
the list ComboList. Click on Settings…. Under the Text Color tab, set the Select
color: value to White. Under the Position tab, set the Vertically (Y) value to ‐360.
Under the Presentation Options tab, select only the Erase Screen. Click OK. Under
the Input tab, select After any response from the participant, Record and save
response, and Reset RT timer. Go to the Correct Response tab. Select all the
words from the ComboList list above that were highlighted; be careful as you have
to be exact. In the …the correct response is: field, choose One or more of the
following: and select Right word correct (3). Now select the words from the list
that were NOT highlighted above. Set their correct response to Left word correct
(1). Click OK. Save the experiment.

13.

Create a new audio event called AudioFiles that chooses files from a list you create.
Use Add Files…. to build up the new list called AudioList containing the following
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files from Applications > SuperLab > Basic Procedures Experimental Files (in
this order—be careful, while there are no repeated files, there are still numerous
opportunities for error):
myu1.wav, fou1.wav, for1.wav, fyu1.wav, mor1.wav, fyr1.wav, myu2.wav, for2.wav,
myu3.wav, mou1.wav, fou2.wav, mor2.wav, myu4.wav, fou3.wav, mou2.wav, fyu2.wav,
fyu3.wav, myu5.wav, fyr2.wav, fyr3.wav, for3.wav, fou4.wav, mor3.wav, mor4.wav,
myr1.wav, myr2.wav, fou5.wav, myr3.wav, for4.wav, fyr4.wav, fyr5.wav, mor5.wav,
fyu4.wav, myu6.wav, mou3.wav, mou4.wav, fyu5.wav, myr4.wav, mou5.wav, myr5.wav,
fou6.wav, for5.wav, fyu6.wav, myr6.wav, mou6.wav, for6.wav, fyr6.wav, and mor6.wav.
In the Sound Option: menu, select only Allow audio to continue playing until it
ends on its own. Under the Input tab, select only Immediately after the event is
presented. Click OK. Associate the event with the Stimuli trial. Reorder the event
so that it appears before LeftWords. Save the experiment.
14.

Create a new picture event called PhotoFiles that chooses files from a list that you
create. Use Add Files…. to build up the new list called PhotoList containing the
following files from Applications > SuperLab > Basic Procedures Experimental
Files (in this order—be careful, there are numerous repeated files):
myu.jpeg, fou.jpeg, for.jpeg, fyu.jpeg, mor.jpeg, fyr.jpeg, myu.jpeg, for.jpeg, myu.jpeg,
mou.jpeg, fou.jpeg, mor.jpeg, myu.jpeg, fou.jpeg, mou.jpeg, fyu.jpeg, fyu.jpeg, myu.jpeg,
fyr.jpeg, fyr.jpeg, for.jpeg, fou.jpeg, mor.jpeg, mor.jpeg, myr.jpeg, myr.jpeg, fou.jpeg,
myr.jpeg for.jpeg, fyr.jpeg, fyr.jpeg, mor.jpeg, fyu.jpeg, myu.jpeg, mou.jpeg, mou.jpeg,
fyu.jpeg, myr.jpeg, mou.jpeg, myr.jpeg, fou.jpeg, for.jpeg, fyu.jpeg, myr.jpeg, mou.jpeg,
for.jpeg, fyr.jpeg, and mor.jpeg.
Click Settings…. Under the Size tab, specify a frame size of 108 width and 144
height. Under Presentation Options tab, select the Erase screen before
presenting stimulus and the Keep stimulus invisible. Under the At Event End:
menu, select Do Nothing. Click OK. Under the Input tab, select only Immediately
after the event is presented. Click OK. Associate the event with the Stimuli trial.
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Reorder the event so that it appears before LeftWords and after AudioFiles. Save
the experiment.

15.

Run the experiment to see if it works to your satisfaction. Give the participant a
name and make sure that the Save collected data option is checked. When you click
Run, you will be prompted to specify a filename and location for the data file. After
running it, locate your data and view it.

16.

One thing that’s still needed is a mechanism for collecting background data on the
participants. To do so, create a new block and a new trial, both of which are to be
called Demographics. For this experiment, you’re interested in determining the
following background information: Sex, age, education, provenance, urbanity of
upbringing, and nativity of English speech. Each page requesting one of these pieces
of information will need to be an event. Create the following text events: Dem_Sex,
Dem_Age, Dem_Educ, Dem_Prov, Dem_Urbn, and Dem_Spkr. Associate the events
with the Demographics trial and the trial with the Demographics block. Save the
experiment.

17.

Use the Experiment > Participant Input… menu to create a new keyboard‐string
input called Background responses. This will trigger a warning, but click OK. Under
the Response Completion tab, make sure maximum number of characters is set to
7. For the SuperLab Assumes That the Participant is Done: menu, select After
clicking on a button labeled Next >. Under the Options tab, in the Show String
Input’s Edit Field: menu, select Only if an event designates a string response as
correct. Click Done. Save the experiment.

18.

Go to Dem_Sex. Have the program use the following text:
Before the experiment can begin, you must first provide
some background information about yourself.
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What is your sex?
(press m for male, f for female)
Under the Input tab, make sure that both After any response from the
participant and Record and save response options are selected. Under the
Correct Response tab, set the correct response to One or more of the following:
Demographic responses. Click OK. Save the experiment.
19.

Configure Dem_Age exactly as Dem_Sex, but with the following text:
What is your age?
(enter how old you are in years)
Save the experiment.

20.

Configure Dem_Educ exactly as Dem_Sex, but with the following text:
What is your highest level of education completed?

(press a for high school, b for college or technical/
professional school, c for grad school, d for other)
Save the experiment.

21.

Configure Dem_Prov exactly as Dem_Sex, but with the following text:
Where would you say you're from?

(enter the five‐digit ZIP code for the location that
best describes where you're from)
Save the experiment.

22.

Configure Dem_Urbn exactly as Dem_Sex, but with the following text:
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Would you say you’re basically from the city (press a)
the country (press b), or both (press c)?
Save the experiment.

23.

Configure Dem_Spkr exactly as Dem_Sex, but with the following text:
Is English your first language?

(press y for yes, n for no)
Save the experiment.

24.

Reorder the Demographics block, the trial associated with it, and the events
associated with the trial to appear first in their respective lists. Save the experiment.

25.

At this point, the experiment is ready to run. However, currently, the experiment
always serves up content in the same order. You can randomize the Block1 block so
that participants get randomized content every time the experiment runs. Click on
Block1. Under the Randomize tab, select Randomize the trials in this block and
Once per participant. Click OK. Save the experiment.

26.

Run the experiment to make sure it does what you want it to do.

2.4. Extending the experiment.
Again, it is a good idea to go back and create a Practice block to give participants the
opportunity to work out the mechanics of the experiment before data is to be collected. At
this point, such a task should not be difficult for you. Simply follow the steps outlined above
while keeping in mind the purposes the block will serve. You’ll need to locate audio and
visual cues to use in the three‐to‐five event repetitions. Also, don’t forget to change your
introductory text accordingly. See §1.4 for more details.
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3. Overview of SuperLab 4.
SuperLab 4 is a software tool for designing and organizing experiments and collecting
experimental data from participants. Using the program, therefore, typically involves
creating or modifying and eventually running an experiment.
3.1. Creating a new experiment.
Opening SuperLab 4 usually sets up a new experiment template. If it does not, click on New
Experiment under the File tab. You are now free to modify the blank template to create
whatever experiment you have in mind.
3.1. Organizational scheme.
One of the most important things to know about SuperLab 4 is that it organizes the
components of an experiment according to a visual ascendency hierarchy in the horizontal
plane. Items on the left hand side of the screen are conceptually “larger” than items on the
right hand side. Thus, blocks can be supersets of trials, which in turn can be supersets of
events. The reverse is not true. Additionally, within each of these three areas, items exhibit
a secondary vertical hierarchy of ordering. So, events closer to the top of the page occur by
default before those closer to the bottom.

Sooner

Later

Larger

Smaller
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3.2. Toolbar.

Most of the operations you will need to get started on a new experiment show up as icons
on the toolbar. The toolbar commands from left to right are as follows: New Experiment
(shiny document), Open Experiment (folder), Save Experiment (disk), Cut (scissors), Copy
(pair of documents), Paste (clipboard and document), New Item (), Edit Item (writing on
document), Delete Item (), Move Down (), Move Up (), Run (), and Help ().
3.3. Components of an experiment.
The basic units for working with experiments in SuperLab 4 are as follows:
Block

This can be thought of as a generic container capable of holding one or
more trials. SuperLab 4 runs experiments at the block level, not at the
trial or event level. So, when running an experiment, you are free to
choose which blocks of an experiment to run. However, you can only
run trials or events somehow associated with blocks (see below).
Blocks are required components of any experiment.

Trial

The term ‘trial’ is something of a misnomer. While it can be and
indeed is the unit into which experimental trials fit, it is also just the
level hierarchically lower than the block. For example, a block
organizing only the display of instructions will have a trial component,
although it won’t actually try anything. Like blocks, trials also are
generic containers. But, unlike blocks, which hold trials, trials hold
events. Each experiment must have at least one trial.

Event

The event is the level at which most experimental actions take place.
Events can be almost anything, instances of text, audio‐visual
material, prompts for data collection, and so on. Whereas blocks and
trials are more structurally oriented and behind‐the‐scenes, your
experimental participants will have direct involvement with your
events. An experiment must have at least one associated event to run.
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There are also other necessary components to experiments, such as Participant Inputs and
Stimulus Lists, and optional ones, too, like Codes and Macros.
3.4. New experiment design.
Designing an experiment that will run in SuperLab 4 involves three major steps—creating
the various items, associating them with one another, and specifying their properties.
Let’s look at each in turn.
3.4.1. Creation of new items. Creating a new item involves merely selecting its unit area
(Blocks, Trials, or Events), and clicking on the New Item icon in the toolbar. SuperLab 4
then prompts you to name the item and gives you the opportunity to specify its properties.
You can always return to the item to specify its properties later, so this step can be delayed
as long as needed. However, you must give new items names before leaving the prompt. Be
sure to give them useful, descriptive names that help you remember what function they
serve in the overall structure of the experiment. Note that item names must be unique only
within a unit area. That is to say, for example, no two blocks can be called “Matched Guise,”
but you can have a block and a trial both with the name “Matched Guise.”
3.4.2. Association of items. SuperLab 4 combines items by way of association. You can
associate any item to any other item one unit higher. That is to say, you can associate a trial
with a block or an event with a trial. But you cannot associate an event directly with a block
without first associating it with a trial and then associating that trial with the block.
3.4.2.1. Making associations. When you create new trials or events, they appear in
their respective areas with a small box to the left of their names. To associate a trial with a
block, you must first make sure that there is no grey highlighting around any item, such as
the following:
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To get rid of the highlighting, simply click in the white “field” of the unit’s area. In the case
of the example above, you could click just below the words “Introduction Test” in the event
area. When all grey highlighting is gone, click on the block you wish to associate the trial
with. This will create blue highlighting on the block name and turn the squares next to
trials blue. To associate trials with this block, simply click in the blue square next to a trial’s
name. Check marks will then appear in the squares to show that the trial has been
successfully associated with that block, as in the following:

Here, the trial “Reaction Time Trial” has been associated with the block “Second
Experimental Block.” Associations between events and trials follow the exact same process.
Note that a single item can be associated with more than one larger item. For example, the
item “Cue” above can be associated with both “Recognition Trial” and “Reaction Time
Trial.” In turn, a block or trial can have numerous items associated with it.
3.4.2.2. Reviewing associations. After associating items, you can always review which
items are associated with which others by simply clicking on the item name of the higher
unit. That is to say, clicking on a block will reveal all of its associated trials, and clicking on a
trial will reveal all of its associated events.
3.4.3. Specifying properties of new items.
Most of the design work in SuperLab 4 involves specifying properties for items. You can do
so either when you create them or at any point after that. To specify the properties of an
item that already exists, just double click on it to bring up that item’s Editor window. The
window provides most (but not all) of the fundamental properties you will need to specify
in order to achieve your desired results plus many others you may never need to deal with.
Fortunately, the process of specifying properties is all done graphically, and does not
involve any special programming knowledge. However, it does involve a very clear
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understanding of the things you want to accomplish. Nowhere is this truer than with
events, which are not only the units that experimental participants actually work with but
are also the units that control how data is obtained from them. As a consequence, there are
more properties to specify for events than there are for blocks or trials.
3.4.3.1. Specifying properties of events. The properties of events appear in the Event
Editor just below the name where they are organized into tabs representing the order of
presentation to the user (experimental stimuli come before the participant’s response
input, which comes before evaluation of that response, which comes before feedback, etc.).
The most crucial of these is probably Stimulus, which is where you specify what kind of
event it is, when and how it is selected, etc. Chances are that you’ll be working mostly with
Audio Files (don’t use Sound File types—they are only there to make the program reverse‐
compatible with older experiments), Movies, Picture Files, and Texts. There is a great deal
to learn about specifying event properties to make the experiment function the way you
want it to function. Please see the SuperLab 4 manual for information on how to maximize
experimental functionality.
3.5. Running an experiment.
Running an experiment for the first time involves some planning of how and where you
want the data saved. Planning the experimental group, therefore, must occur before you
run the experiment with participants.
3.5.1. Participant groups.
The first step in the process is deciding whether or not you want to group the participants
in any particular way. For instance, if you are running the experiment on one of the laptops
both in the field and in the lab, you might want to have field participants in one group and
lab participants in another. That way you can later make a case for control of location if,
say, laboratory trials ran faster on average than field trials. Or, you may not need to group
participants in any particular way. At any rate, you can create groups in two ways. The best
way is found under the Experiment > Participant Groups… menu. Here, you can add or
delete groups and modify their properties, which includes which blocks will be run for
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which groups and narrative descriptions of the groups themselves. The other way to group
participants is at the time of running the experiment. However, if you’ve managed to come
that far with your experiment and have still yet to think about groups, there may be other,
more serious problems with your experiment!
3.5.2. Individual participants.
When actually running the experiment to collect data, you’ll probably want to save the
unique results of the experiment for each participant. As such, SuperLab 4 prompts you to
provide a name for the participant when you click the Run icon. Remember, though, that
the name you choose for the individual is the only piece of information you have linking an
individual to their personal responses within the data. Accordingly, coding participant
names is the best means you have of protecting your participants’ anonymity. Consistency
is the key to this; if you plan on collecting experimental data from less than 100
participants, you may code names as Subject_01, Subject_17, Subject_82, etc. If you use a
table of random numbers to draw their number, regardless of their order of participation,
you provide an additional layer of anonymity. Such a table is provided in Section 3.7
Note also that SuperLab 4 saves data obtained from participants in a folder of your
choice. If you are not careful about where you save things, you may overwrite or lose
valuable data, especially if you’re running two separate experiments at the same time. Or
the same experiment on two computers.
3.6. Viewing and using data.
SuperLab 4 saves data obtained from each participant in a separate tab‐delineated text file
in a folder of your choice. Columns in the file represent the types of data SuperLab 4 saves,
such as participant response, correct response, reaction time, etc. Meanwhile, rows
represent the actual values for those types, such as “Space (continue),” “Left word (1),” and
“1497“ (times are in miliseconds), respectively. Because the individual values may be of
varying sizes, the columns rarely line up when viewing the file in its native format. This
makes it very difficult to read, and suggests that there are better ways to view the text than
as a .txt file. There are several ways to view and organize data, including the Cedrus Data
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Viewer and MS Excel. Many students and faculty are very proficient with Excel, but most
have neither heard of nor worked with Data Viewer.
3.6.1. Cedrus Data Viewer.
The program Data Viewer allows you to view the results of your experiments quickly and
easily. In fact, you can open numerous .txt files at the same time, merge them into a single
file, sort by type or value, hide unnecessary rows or columns, convert row data to columnar
data, copy and manually export selected data to MS Excel, etc. Furthermore, it’s a free
download that doesn’t require SuperLab 4 to use. This means that you can run your
experiment on a computer in the Sociolinguistics Lab and do your analysis at home.
Download Data Viewer for free at http://www.superlab.com/dataviewer/.
3.7. Random number table.
Below is a small random number table for use in assigning codes to participants. The table
lists the numbers from 0‐99 uniquely. To use the table, select a method for navigating it
consistently, such as left‐to‐right starting top‐to‐bottom (18, 50, 53, … 25), top‐to‐bottom
starting right‐to‐left (91, 71, 32, … 21), etc.

18
81
52
27
06
98
89
14
79
21

50
59
44
54
93
20
62
85
88
83

53
47
34
55
77
86
28
02
82
43

68
08
42
24
58
72
13
60
64
22

38
48
07
74
41
87
29
76
04
73

49
67
56
92
30
16
65
90
51
96

31
33
23
75
19
99
78
00
17
46

09
40
45
36
03
66
11
95
84
57

70
12
97
10
15
01
37
26
61
05

91
71
32
69
80
35
39
94
63
25

